Chinese character or UTF-8 setting during process the DB connector

Dear Support Team,

When i use DB connector to insert some values into MS SQL DB, i found unidentifiable Chinese characters in the DB. Meanwhile the English characters are correctly insert to MS SQL.
The column in MS SQL DB already set to nvarchar type.




Normally when we try to in insert Chinese character into MS SQL, i am following the syntax,
insert into tablename (column1, comuln2) values (N’Vaulue1’, N’Vaulue2’);

But this N seems not working in Tulip connector syntax?
(N’$Applicant$’,N’$Department$’,…
image
If i only put N, also met error below,
image

Could you please help me know how to transfer the message via UTF-8 or other format?
Or what else settings i missed?

Thanks in advance!

hello @Ruijia - great question, thanks for posting!!

can you try using CONCAT('N', $input$) in the SQL query?? I would try on your behalf, but don’t have MS SQL to test unfortunately.

I’m also eager to hear input from others if someone has come across this.

Hi Gio,

Could you please help me to correct if my syntax is not right? Thanks.

image002.jpg

Hi Gio,

I also tested ‘N’+$input$, not working…
image
But if if directly put the Chinse characters in the testing, it works…
image

DB result is as below,
image

May i know if Tulip has DB connector debug function for messages analysis?

Thanks.

Same problem here. No special chars inserted here:

Tried to insert: šđčćž ŠĐČĆŽ
Inserted:
image

As mentioned above “N” syntax works:

Hi @ermingut and @Ruijia,

We’re investigating this on our end and will work to understand what is going on with special characters getting passed to the connector function. I’ll provide an update ASAP on our findings.

Thanks!
Grant

1 Like

Hello @Grant ,
May i know if you have any found out? I heard about Tulip have project in China WuXi, not sure if you have some connection with that project support team and could get suggestion from them?
Thanks

Hi @Ruijia! Yes, we have been able to do some investigation and believe we’ve identified a possible solution here. We’re looking to add explicit support for nvarchar datatypes in the connector - I’ll let you know once I have an update from Engineering on the time frame. Your account manager for these Tulip projects is also working to escalate prioritization with the team as well!

1 Like

Hello Grant,

I had more testing for this case as below,

  • The MSSQL accept Chinese characters, the code setting is ‘SQL_Latin1_General_CP1_CI_AS’
  • When we want to insert Chinese characters into MS SQL, we need add ‘N’ as the prefix. Such as below,

insert into Tulip_MD_Master values (N’西安杨森Test1’,‘IT’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’);

image001.jpg

  • But when follows your example, the ‘N’ will be also inert into the DB. This why in below testing result it becomes confusion code.

insert into Tulip_MD_Master values (‘N西安杨森Test2’,‘IT’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’,’’);

  • During the Tulip connector transfer the message, seems it add ‘’ for the parameters, but don’t know how it could add N instead of adding ‘N’ in front of the Chinses characters.

Thanks.