Custom Widget AutoSave

Hello,

For 2 times today, the Custom widget page I was working on (in the editor) refreshed and I lost every modification I did since last save. Isn’t it an AutoSave function when modifying/creating a Custom Widget?

I would love to have this functionality if it is not already there.

KR,
Kevin

HI @kefl,

to be honest I don’t like an autosave in custom widgets, because I want to try something out and then simply don’t save, if I don’t want to.

In your coding area, it seems to work hitting ctrl+ s for saving, without leaving the Widget.

What I actually find worth mentioning, is the fact that the page refreshes without asking an then looses the unsaved work!
@Beth could you check if somethin is going on around this topic?

I also mentioned this issue before and I think we two are not alone. This should actually be tackled!

2 Likes

Hi @thorsten.langner and @kefl - I will check with the team on the unexpected refreshing in custom widget editor! stay tuned

Hi @Beth unfortunately that’s not limited to the Custom Widget Editor.
This happens in all environments from time to time.
I experienced losses in: Trigger Window, SQL Connector function editor, HTML Connector function editor, Custom Widget editor.

In case of triggers, you cant even save in between, because unfinished triggers are not savable…

1 Like

Thanks for reporting, @thorsten.langner @kefl. Custom widgets (and other things like connectors, triggers, etc) are all supposed to prevent navigation away while you have unsaved changes. However, I was able to reproduce this as well – left the window open in the background and the change disappeared. Might be from Chrome re-loading it to conserve memory for tabs in the background? I’ve filed a bug for us to look in to

4 Likes

Hi @mglidden,

thanks for looking into it.

After your response, I had an Idea and it could be a solution.
In Edge and Chrome there is an setting to put pages into “Standby” or “Sleep” mode, when they are “not in use”.
This depends on the pages action (e.g. video and audio will increase the duration…).
I added our TULIP instance to the exception list and that prevented at least the reload from waking up after standby…

However, I’m not sure, that this is the only reason. I’m relatively sure, I also experienced it once or twice, while actually working on that page!

Maybe the page can be built to be recognized as active from the browser?

I think you’re right – there are multiple causes for this, the standby mode being one of them. In my testing yesterday, I saw it happen when the page hadn’t gone into standby mode, which we’ll investigate.

1 Like