DatePicker Calculations

Using the Date Picker, however the date picker here in UK, displays the time with an +1:00, which is confusing, the time is correct, but when trying to add 24Hours (84600 seconds), I get a different time, but confirming the duration by subtracting the values, I get 1 Day

anyone got any ideas as to why this is happening?

Selecting the Date Picker to get 30/08/2022 09:02:00 +1:00
Adding 24 Hours onto that selected value using expression
variable.CleanStartedPlus24 : variable.Clean_Started + 84600 gives me 31/08/2022 18:02 +1:00

subtracting using expression
variable.CleanStartedPlus24 - variable.Clean_Started gives me 1D 0:00:00

why am I getting a different value for the 24 Hours, it should be 31/08/2022 09:02:00 +1:00

any ideas

Many thanks for looking

Hey @Spikenaylor -

So the +1 is just indicating your offset from GMT, We display datetimes in the ISO8601 format, which expects this offset to be called out (imagine for a second you convert this to text then store it, you need the offset when reloading it to understand what timezone the time reflects).

I approached adding a day a few different ways and couldn’t get it to fail, here is what I tried:

Can you drop a screenshot of your trigger? Sometimes we see cases where that context around timezones is lost, so adding time is no longer correct.


hi there, many thanks for looking
tried your solutions and whilst the maths work, the result date and time is not displayed correctly for me. the time period works when I am checking against it.
As you can I have added 24 hours on to the Clean Start, but the result date and time is not displaying 24 hours added on,

Hey @Spikenaylor -

What are the chances you can join one of my office hours sessions today? I can’t access your instance myself to dig into this a little deeper.

Thursday 11AM EST - - General Office Hours

Thursday 4PM EST - - New User Office Hours


Hi all, we found the issue, our Development instance of Tulip was set to Australian time zone which was affecting the result somehow. All sorted, and our Pre Prod and Prod instances are confirmed fine for time zones.

Hey @Spikenaylor -

Thanks for updating us! Was it the timezone configuration for the station?