Machine Timeline Downtime Reason

I am having an issue where I have a machine timeline embedded in my application, which allows you to “review downtime”. When I select the review downtime button it allows me to select a reason for the periods of time where my machine wasn’t running which I like. However, the reason is populating my machine activity there after for both when it is not running and when it is running. For example, I selected “Resource” as my reason for my last downtime, and since then, my activity table is populating the downtime reason to be “Resource”, even when it is running. See attached screenshots. Has anyone ever come across this before and have a solution?

Hi Meghan,

Thanks for posting this. As a short answer, it’d be most impactful to add an action into your machine type trigger that handles creating states. If switching to something that isn’t a downtime state, clear the downtime reason from the state that will be created. Make sure this action comes after the state creation, so you don’t accidentally remove it from the downtime state it should be associated with.

The longer answer is that some fields default to clearing their values on a new row, and some default to keeping those values when a new row is created. In custom activity fields, you can dictate which setting your field will follow, shown below.

Since this one is a default field, we unfortunately can’t change that behavior directly, as we would with a custom field.

I would certainly agree that Downtime Reasons should default to clearing when a new state is created. I’ll submit a product request to change the default behavior here in the future.

Let me know if this is helpful or if you have any follow up questions.


Hi Brian,

Thanks so much, that helps a lot.