Analytics Tab has no delete button

The analytics tab has no delete button, I looked everywhere and I cant find it

No Delete Button Analytics

1 Like

Hey @mkucker , good question. You likely have a user-role that doesn’t have permission to remove analytics. I would check with your account admin to see what your role is, and to see if you can get your access levels adjusted.

The Tulip user roles that have remove permissions are:

owner
workspace-owner
admin
shop-floor-admin
connectors-admin
tables-admin
apps-admin
apps-builder-admin
shop-floor-operator

You see the full breakdown of roles and permissions here.

I just double checked @John I’m the account owner, also the other account owner doesn’t have the delete option either. Thanks

@mkucker, thanks for the quick response. Let me run this past our support team really quickly—my understanding is that account owners should have this permission so let’s see what’s going on here.

Okay, I think this is the last question: are you looking at the analytic on the dashboard or the App Overview >> Analytics page. If it’s the App Overview >> Analytics, once created there’s no way to remove analytics from here. This is something that’s on our product team’s radar, and I’ve flagged this with them.

1 Like

Its the App Overview >> Analytics, good to know that its being worked on. Thank you for the help!

Util now this issue is still not fixed if this is really an issue or maybe this is by design.

This is a major issue for us too, we’ve built a lot of analytics for user demos and case studies and once you do, you are stuck with them even if you never intend to use them again.

I’d also be interested to know what the overhead is with these analytics remaining in the cloud, do they ever run or refresh?

Great question!

Generally Analyses only refresh / run when they are viewed - in a dashboard, or in an app.

There is only one exception: Alerts. When an analysis is configured with a Layer and an alert, then it is executed hourly and evaluated for new insights, which would trigger an email.

2 Likes