I don’t know any document but would also be interested. We could just start this thread as a log of any best practices people would like to share.
Here are some of mine:
Always name your triggers; More of a necessity if you have multiple triggers on one step, but it’s good no matter what I think
Utilize step folders
Come up with a variable naming scheme and stick to it; My preferred method is stepFolder.variableName If you have a lot of variables in an app a good naming scheme will cut down on time searching through your variables.
If a button or shape has a variable color make the default color something outside of your app color scheme to make it clear that the color/transparency are variable.
Some best practices I would really be curious about are trigger best practices. For example, when creating complicated actions is there a performance difference in having multiple triggers on one button press vs. a bunch of if-else statements within one trigger?