Can't Create Table Record Via App


Didn’t find Community post with similar issue so posting here.

I type material into a variable field. I click “create QN” button to create a table record with text value from a variable.

This trigger doesn’t work. I get “there is no record loaded into placeholder” error:

I tried another trigger below not in a test but run mode via Tulip player. Instead of creating a new table row record with ID = 1 and material = 123 it created ID = 123 and empty material.


Which trigger should I use to create a table record where entered variable gets written into material column and ID column just increments by +1?

Also, what if I have multiple variables that need to be written into multiple table columns as a one row record upon clicking a button with a trigger? And have ID column increment by +1? Here is a more complex table I am referring to:



create a record as you did but with the incremented id instead of the variable.

you can increment the id like so:

then this created record is loaded automatically and you can push your variable in as you tried with your first attempt (first screenshot).

1 Like

Thank you so much! This is the solution!