Player File Viewer not displaying uploaded PDF

I can’t view files I’ve uploaded to Tulip through the player on Android.

Here’s the app. Bottom right corner has a Table Record widget connected to my files.

Here’s how the app behaves on Windows

File Upload on Windows

Here’s how the app behaves on Android. I’m using BlueStacks 5
Looks like it’s running Nougat 32-bit

File Upload on Android

Once I gave it permission to download files and uploaded a pdf viewer, the android system could see the PDF that was downloaded. It couldn’t view it in the app though.

Ideally the my users wouldn’t have to mess with any apps outside of Tulip. I’d like to view the pdfs in the app the same way I can on my work PC running Windows 10.

If I can provide any clarification I would be happy to go into more detail! Let me know if you’ve seen something like this before.

Thanks for your help,


@TechnicallyKatie You can tell me if you’ve already tried this, but what happens if you click “allow” and give Tulip permission to access files on your device? My initial reaction is that, because you clicked “deny,” Tulip can’t pull the local file into the application.

That would make sense, since I didn’t post the last GIF I took! Sorry for the confusion. once I downloaded a PDF viewer I could see the pdf on the android screen, but still not in Tulip. Sorry for the vertical, the reader insisted it could not be in landscape.

PDF viewing on Android

Permissions and PDF reader installation aside, does this capture the issue that still remains:

On Android, clicking link to a PDF opens in a reader but will not open in player as expected in Windows

Correct. Sorry for the late reply.

It is the same issue in IOS as well. When I load the pdf document as a variable it just shows the first page with no scroll or zoom in or out ability. And when I tried to open the same document again, it shows only white screen for that particular section with no information inside.

Also, for some variable it does not even load the pdf.

That is good information Amir, I don’t have any iOS hardware to test on here. Having it show just the first page is interesting. If you get a chance, could you upload a GIF or some screenshots showing what it looks like?

I opened a ticket for this and will report findings back here. Thanks for reporting.


Here you go! You can see in a video that it only opens first page and I can’t zoom in as well. Also, as I mentioned, opening same page again just shows white screen.

Same is the case when I turn it to landscape mode. For landscape it does not even open the file, it requires me to turn it to portrait to load and than again just only first page can be viewed with same problem. (No Zoom or Scroll)

Changed the topic from “Troubleshooting and Support” to “Product Suggestions”.

1 Like