Save image of a tulip table to google drive

Hello Community,

I am trying to upload images from a tulip table via connectors to google drive.

I have tried to get the signed url successfully via tulip apis but i still do not have an idea to upload this urls to google drive. i tried to open the urls via browser but still prompts
“Public access is not permitted on this storage account”

Is there any way to achieve so i can view the image in google drive? thanks for your time

Hey @charlie this is a great question. My first thought from this error is that there are a few likely culprits:

  • The first is that there’s a permission issue in Drive that doesn’t allow 3rd party read/write. If your permissions in Drive are set, it could be an OAuth2.0 issue in your connector config. I would make sure that OAuth is set up correctly. We have a decent video overview in this article if you haven’t already seen it.

  • The second is that it could be a scopes issue on on the GCC side. I would double check that you’re credentials have the correct write scopes for this Drive API.

  • Finally, the last thing to check is if you’ve enabled the Drive API on the GCC end. It’s easy to miss and has tripped me up before.

Let me know if this does the trick