Add Custom Barcode Scanners Option not available

Good afternoon,

I am trying to connect a Honeywell 1950 barcode scanner via my gateway. This does not seem to work as a plug-n-play solution. Now I have tried to add it as a custom barcode scanner in the player but, that option is not available for me. The dropdown ‘Tools’ only shows ‘Barcode Scanner’. Some help to point me in the right direction is appreciated.

Thanks,
Anja

Hey Anja,

The “Custom Barcode Scanner” option in the Tools menu is only available on Windows. If you’re on a Mac, you won’t see it.

What happened when trying to connect via the Gateway?

Can you confirm the following is true about your device:

  • Most barcode readers can be configured to either behave as a keyboard, or as a virtual serial port. Tulip requires barcode scanners to be configured such that they behave like a keyboard .
  • The barcode reader must output in keyboard mode, with a newline at the end (or CR suffix).

Here’s our Support Article on connecting Barcode Scanners to Tulip: How to Set Up a Barcode Scanner | Tulip Help Center - Support for Building Manufacturing Apps

1 Like

Hi Kailey,

Thank you for clarifying - I already assumed that me not seeing the menu was due to my use of a Mac. But if I don’t set up the scanner via the menu in the player, how do I know which device to chose from when I want to use the scanner in my app? I have tried all of them but are not seeing any inputs in my app (Tulip).

I am pretty sure that I have it setup correctly as it inputs a number + backspace when I connect it to a Windows PC and just have it input in a word doc.

Can you please check that I am using it correctly in my trigger? I am using a Machines & Devices trigger on the step.

Thanks!
Anja

hello @Anja,

could you confirm that the Player from which you are testing the App and the Gateway are assigned to the same Station?? alternatively, have you attempted selecting the actual Gateway Serial Number instead of this station??

Hi Gio,

I can confirm that Player and Gateway are assigned to the same station.
I have just now tried to select the select the serial number instead of ‘this station’ but this does not show up in the dropdown menu.

thanks for confirming @Anja!!

however, not seeing the Gateway populate in the dropdown is quite odd. could you share a screenshot of the Gateway page and the Station page on your instance?? thanks!!

Hi Gio,

adding the 2 screenshots here.

Best,
Anja

OK, thanks for sharing @Anja - everything looks correct.

just to confirm, have you gone into your Gateway to add the USB Barcode Scanner?? the page will look like:

I have not done that. This might be the issue!
Where do I get the information for the Vendor ID and the Product ID?

@Anja, yes that could indeed be the issue!!

this Support Article includes documentation on how to find the PID and VID for your barcode scanner (you’ll se a link to this article in the documentation).

let us know if this helps!!

Hi Gio,

I have added the barcode scanner to the gateway now. Should I be seeing the name I have given the device in the dropdown now? Because that is not the case so far and I cannot seem to get this to work either.

Thanks for your help,
Anja

hello @Anja,

no, the dropdown will populate with the Gateway Serial Number (which will start with GTW-). are you seeing available Gateways on your instance??