Connector fails (times out) seemingly at random

Here is me running the same connector 6 times in a row (gif below).

Attempt Result Time
1 Fail 20 seconds
2 Fail 20 seconds
3 Success Immediate
4 Success Immediate
5 Success Immediate
6 Fail 20 seconds

Every time I run this in the ERP, it works, and in WAY under a second (typically 100ms). I’ve tried it dozens of times.

Any thoughts, or should I just put in a ticket?


hello @JasonMcD, thanks for posting and sorry about the challenges you’re having with these Connector Functions.

I have a couple of questions to help troubleshoot here:

  1. is the Connector in Development of Production?? as you can see here: What are Connectors? | Tulip Help Center - Support for Building Manufacturing Apps (Timeouts in Connectors section) the timeout changes depending on the environment
  2. have you tried using an API service such as Postman or Insomnia?? if so, are you getting the same variability??

thanks again for posting


Works fine in Postman. Here are 12 tests in a row working well.

Hey Jason,

Could you please submit a Support Request through your instance for this issue?


1 Like

Will do. Thank you. @Kailey and @gio

1 Like