Delete a record by id from Tulip table

Hello,
I have a Tulip table that contains ID and 2 fields, Article and Article description, I created a step where the user can handle this table (insert new record, update existing, delete existing), the insert and update operations works great but the delete not.
I tried to do :


But gets the error that the record is in use.

Then I created a connector function of Delete for this operation, and get a similar reaction :

I also replied to an existing topic in the forum but this was before I tried to connector function tool, so here I wrote everything I did.

So, how can I delete an existing record from a table ?

Somewhere else I so a use for “records?allowRecordsInUse=true” inside the URL but when I’m tring to use it, I get :

Please help,
Thank you,
Amit

hello @Amit, thanks for posting!!

have you attempted the Action Clear Record Placeholder prior to deleting the Record?? once you use this Action, you will be able to delete the Table Record.

could you try this and let us know if it works?? thanks!!

Thank you Gio,
Now the deletion working great !

But if I do want to do the deletion by a connector function, what did I do wrong there ?

Amit

hello @Amit, great to hear!!

so it looks like you’re using the parameter allowRecordsInUse, on the endpoint used to delete an individual Record (passing an ID), but it only exists on the endpoint to Delete all Records from a Table (without passing an ID).

furthermore, the parameter has to be at the end of the URL.

as you see here, I’m successfully Deleting all Records including the ones in use:

however, the endpoint to Delete an individual Record doesn’t currently support the allowRecordsInUse parameter.

feel free to post in Product suggestions - Tulip Community if you’d like to suggest this to our Product team!!

Gio,
Ok, thank you for that, I will add an issue there

Amit