How to enable Node-RED

Hi,

I noticed that Node-RED was made available on the recent update to my Edge MC device. I clicked on the button to enable it, but was given an error message “Unable to start service ‘node-red’”. I also restarted the Edge MC and tried again still with the same result.

What can I do to enable and begin using Node-RED on my device?

Thanks,

Alan Madorin

Hi Alan,
Have you already tried doing a factory reset on the device? This may be required to enable the node-red when migrating.

1 Like

Not yet. I can try that.

Reset did the trick. Thanks!

1 Like

What do I use to log in…?

Screenshot 2021-02-02 123322

I ended up guessing it. The username is “Admin” and the password is the same as the Edge MC login password.

1 Like

@Alan.Madorin – if you OTA the OS prior to OS38, you must factory reset. Production hardware OS38.1 and on does not require this.

Has anyone had any luck loading new nodes into the pallet manager for Node-red? Every time I try I get a loading icon and then nothing.

I had no issue with it.

I think it was an issue with our network security. It seems to work fine on an outside network.
Thanks,

1 Like