NetSuite OAuth2.0 connector setup issues

Hey all, I am having a lot of trouble getting a NetSuite connector working with OAuth2, or finding any useful information on the topic. I’ve tried to follow help articles in the Tulip knowledge base, with no luck so far. This article suggests a pretty straightforward process, but the OAuth 2 (Admin) and OAuth 2 (Operator) options are not available to me as pictured in the documentation, despite me being an account owner. Not sure if that documentation is simply out of date? In any case, OAuth 2 (Bearer) is the only option I can select.

I have installed the Manufacturing Control NetSuite App Suite for the purpose of inspecting the included NetSuite connector, but this has only added to my confusion.

My understanding is that NLAuth is, by definition, not part of the Oauth2 protocol. I also have no idea what opaque value I should be passing as the NLAuth header. Also also, I understood NLAuth to require headers like nlauth_account, nlauth_email, nlauth_signature, etc. I can’t find any documentation of NLAuth by itself being a valid header.

Would someone be able to walk me through setting this up or pointing me to documentation that addresses the OAuth 2 (Bearer) setup workflow specifically? I need to set up the connector to a) not pass an unencrypted password a la vanilla NLAuth, and b) not require regular, manual re-generation of a new auth token.

hello @evan.mccann, sorry to hear about the challenges in authenticating with NetSuite - there are quite a few moving parts.

we currently only support OAuth2.0 for NetSuite, not NLAuth. just to confirm, have you taken a look at this support article?? it walks through all the steps necessary to authenticate to Netsuite from Tulip. let us know if this is helpful.

It looks like the Tulip Integration NetSuite bundle has “Shared” permissions rather than “Public”. As a result, I can’t install it. I get “You have not been granted access to this bundle.”

@evan.mccann - Sorry to hear about the issues you are facing. To better understand the current issue you are facing, can you attach a screenshot of the error you are seeing & at what stage does that happen?

  • Customization > SuiteBundler > Search & Install Bundles.
  • Search for “Tulip Integration”, verifying that the bundle ID matches the documentation Gio posted above. Installing this bundle is the first step in that documentation, and I don’t have permissions to do it which I assume is on your end, since I have unrestricted Admin access in NS.

@Sagarverma Got any direction for me on this? The above support article (this thread won’t let me link to it a second time) says I need the Tulip Integration bundle installed in our NetSuite instance in order to use OAuth2 to connect to NetSuite from Tulip. Am I understanding that correctly? And can I be granted permission to install the bundle? I already have maximum permissions in our NetSuite account.

Hey @evan.mccann,

We were able to replicate this issue. We’re following up with Netsuite to make the bundle publicly available again.

1 Like

Hey @dillon, any progress on making that bundle available? Happy to take this to email if you prefer.

@dillon @evan.mccann Is there any update on this? We were going to start the process of setting up NetSuite with OAuth 2, but it seems like there still some issue with setting it up.

Correct me if i’m wrong, but it seems like the Manufacturing Control NetSuite App Suite at this address Manufacturing Control NetSuite App Suite | Frontline Operations Platform is not up-to-date, since the connector is setup with NLAuth

And the support article at Configuring the Tulip NetSuite Connector | Tulip Knowledge Base - Support for Building Operations Apps might also not be up to date since it references OAuth 2(Admin) and not OAuth(Bearer)

I’d appreciate some feed back on if OAuth 2 will be a viable solution before we begin to build it out in NetSuite.

Nope, I haven’t heard anything. @gio @dillon Any status updates for me?

@evan.mccann Could you try again and let me know if you run into the same issue? We’re still working on it with Netsuite, but I made some minor changes and confirmed that I’m able to load the bundle from our test account.

@ulisesgomez We support OAuth2.0 (Admin) for Netsuite, documentation here. I’ll put in a request for the app to be updated by our Library team, but the adjustment needed is minor. We don’t support the TBA auth flow for Netsuite because it is nonstandard. Is that a blocker for your implementation?