Tulip Analyses Interval not showing as KPI


I want to display a interval as a KPI in a dashboard.
However for some reason i cant get it to show.

if I just select the variable in my KPI, it shows “00:00:00”. and when I try to convert it to seconds it gives me a “0”.

however in my app i can see the seconds go in my variable:


I know I could just use the variable as my KPI instead of using the Number box in my analysis dashboard, but I’m just wondering why it wont show up? am I missing something obvious?

fyi, I’m using the Work Instruction app and the Stopwatch custom widget for this testing

@knowlec, thanks for the question. i want to throw two thoughts out there to get the troubleshooting going.

  1. Most likely problem here is that you’re not using an aggregation function in your expression. Can you see if it works if you add a sum() or average()?
  2. If the analytic is evaluating to 0 second it can also indicate a trigger error when storing data to the variable. Can you confirm that you’re saving the variable and populating it with the right time information?

Hope this helps!

@John hi john,
thanks for your response,
i tried putting a SUM() and a AVG() around the calculation but its still giving me a 0 result

For your second option, i assumed the value was being recorded correctly as it was showing the seconds when i displayed the variable in my screenshot above
Im not saving the variable to a record though, its just in the app and i want to display the interval time each time the app is run without having to save each record