Correct encoding for CSV downloads for display in Excel

If a table contains special characters like Ü,Ö,Ä,Á,À, etc. these are not displayed correctly when opening a downloaded CSV file in Excel. This is due to the fact, that Tulip does not provide information for the encoding of the CSV file. Some tools can identify the encoding of the file based on the content alone - however, MS Excel does needs a BOM to do this.

To enable Excel and other tools to correctly interpret the content as UTF-8, please add BOM character to beginning of CSV File.

BOM character = “\xEF\xBB\xBF”

This will enable Excel to correctly interpret the text as UTF-8 and allow for a more convenience way to open up downloaded files in MS Excel.

Alternatively, provide a setting that allows a customer to select the download format in Tables.

Voted. Many Japanese users really want this!