Edge IO and Zebra printer cannot connect

I connected the Zebra printer to the LAN port of the Edge IO and tried to transfer data, but failed.
After some trial and error, I found that I could connect to the printer from the LAN port of the Edge IO via a hub.
I did not change the IP address.
Is there any way to connect without going through the hub?

I will raise this topic again.
Does anyone know?

Hello, thanks for the post.

If you connect the device to the LAN port on Edge IO, the Edge IO will assign an address using DHCP. You can check the address by going to the gateway portal > logs/diagnostics > dhcp leases

The address will be of 10.0.5.x range.

Thanks for letting me know how to check the IP address.
I will check again.
However, when I tried, I was able to connect through the hub and it didn’t work if it was direct.
Is the IP address affecting it?

I am not sure. Did you check that your previous address was of 10.0.5.x?

The IP address was .

Thanks for the info.
I will check the IP address from the edge IO again.
I don’t have the Edge IO at hand right now, so I will check it as soon as I receive it.
Thank you very much.

Sorry for the late confirmation.
I finally received the Edge IO.

When I check with Edge IO, I see the following.
Only the item “AP” is shown.
Is there any way to check?

Hi @tracy.qiu ,

After several Edge IO restarts, “LAN” now appears.
However, it still does not work when triggered from the app.
Do you know what is wrong?

@da-noguchi, unfortunately @tracy.qiu’s co-op at Tulip has ended so she’s not around to respond to this message, but I want to connect you with @k.ober, who can help you with this question.

Hi @da-noguchi , happy to help.
Sorry that I’m joining in here late, but I’m assuming that we have already confirmed that Edge IO is assigned to the station where you are running the trigger. You do have the correct IP address, and have clicked “Save” on the page (a mistake I commonly commit).

Your trigger configuration looks correct. However, the “print text” function you are sending will only do that; print text. If you want to print ZPL, you must do so with a Template. Regardless, you should be able to print text (for ex., hello world ) with this trigger that I see here.

I recommend two things:

  1. Change your trigger to simply attempt to print the text “Hello World” or similar.
  2. Open the debug logs with the method below, and send back a screenshot of what happens. In player:
    a. Click “Developer” > “Toggle Developer Tools (Content)”
    b. Click “Console” on the top of the window that appears, if it is not already selected
    c. In the bottom of this window, enter $T.Debug.setDebugTriggers(true); and hit Enter. You should have no errors appear in the console.
    d. Click the crossed out circle on the top left of the console.
    e. Click your “Print Label” button.
    f. Observe what appears in the console, and send a screenshot back here.

Hope this helps! Let me know what you run into.

Hi @John ,@k.ober ,
Thanks for your reply.
I am trying to verify what you taught me, but the ‘LAN’ entry in ‘DHCP Leases’ is not showing up again.
Also, Edge IO’s Wi-Fi disconnects happen is often interrupted, so I can’t make any progress in verifying it.
Edge IO’s Wi-Fi disconnects happen not only on this device, is it a network issue?
Is there a problem with the device?

Hi @da-noguchi,

hmm, interesting. Can you confirm the following for me?

  1. Your Edge IO is not pending any software updates (which would be visible on the “Edge Devices” screen in your instance)
  2. There are no cables plugged into the WAN port of your Edge IO
  3. You have confirmed that the cable plugged into the LAN port of your Edge IO is good, either by testing it somewhere else or substituting a new, known-good cable

Wi-fi disconnects can be a couple of things - if these are all true, then I’m going to suggest we migrate to Support so that we can pull some logs and see what’s going on.

Additionally, as a general rule it is always better to use hard-wired internet (if this is available) than wi-fi - I recommend this if it’s nearby.

Hi @k.ober

1-3 all seem to be fine.
3 is not a problem because the printer works from Edge IO through the hub.

I will create a another ticket for Wi-Fi.

Hi @da-noguchi ,

OK, understood. Thanks for checking into this for us.
At this point, I think the best course of action is to contact our Support team so that we can pull debug logs. Can you please open a ticket by emailing support@tulip.co ? Don’t feel like you need to re-explain the problem; a link to this thread should be fine. Thanks!