One Click Link for Launching Tulip Player + Specific App

Hi Tulip Team,

Is it possible to get a “link” to the “Run” button for a certain app? I essentially want to embed the link/function associated with the “Run” button on a SharePoint site to allow folks to open an app in the player with one click (if they have the player installed) - essentially the same as clicking on the “Run” button from the app editor page.



@jas - thank you so much, this is a great start! Let me know if this is incorrect, but seems like it will open the player in Chrome and display the last app that was ran from that device (i.e. it does not open up the app associated with the app id) Tulip.

Also, when you click on the “Run” button via the backend it will open the player with the correct application, is there a link that can do this ? Ultimately someone should be able to click this link on the sharepoint and then (1) the player will launch and (2) the specific app will open, requiring the user to login. Let me know if this is unclear or not possible.

Thanks again for the support!

I was unable to get the tulip-mfg://{url} to work. This was the schema I had to use to open the desktop player.
tulip-player://{instance name}{appId}

@jjj - thank you very much! That schema worked for opening the player, but it does not open the actual app based on the entered appId. Does it open the correct app for you?

@jjj @petrus_geldenhuis Same thing happening to me. That schema is only opening the player for me but not the app by the entered appId.

1 Like

I didn’t pay close attention to that. It did not open that specific app, it just opens the player to a random app (probably the last one run in the player). But I think I may have figured out an alternative. Go to this screen…

If you’re in Chrome, select Developer Tools

Select the Network tab

Hit the Run button on the tulip app, then in the developer console you will see the following. This is the app-specific URL to open it in the player.

EDIT: As @Pete_Hartnett noted below, this will take you to the development version of the app. I don’t think it will work to take you to a published version.


@jjj thank you sooooo much, this worked!!! @Julian - the above from @jjj works! @RussWaddell this is really valuable for situations where folks are running apps from their personal laptops or tablets vs. stations on the shop floor.

1 Like

@jjj Thanks a lot for this

1 Like

@jjj, thanks for sharing this insight. Much appreciated.
A question on this - maybe to our Tulip supporters; I created a link on my desktop to a specific app following the instructions. Works great. Then I proceed to clear all station app assignments, meaning I essentially do not have access to that specific app. But the link still works. Do you see the same?
It would appear to me that it would generate a loophole that sneaks past our management of stations / app assignment.

@ASharp-J -

This thread actually brought up some interesting internal conversations that boiled down to the same thing. That link will always go to the development version of an app and skirts all app assignments. There is work in the scoping phase to make sharable links to apps that don’t skip these checks.



Is this still in progress or already released ?
I would like to generate link to share the specific App which …

  • Only the stations which is configured to open that App can open it
  • Opens the latest released version of the App (does not have to re-generate the URL when it is revised)

Is there a way to make the solution jjj identified work with browser players?

Any update on formal support?

1 Like

To launch an App in the Browser Player watch this post:

Launching a Tulip App with a QR Code or NFC Tag - Show and tell - Tulip Community

Thank you so much @jjj you solved my problem


@jjj love seeing what a long afterlife this post has had! Thanks for taking the time to share.

1 Like

Hi Pete, has this topic had any movement since last year?
Is this in the road map?

I had a batch manufacturing routing app based on app trigger “Complete app then change by app name”. This routing app opens the correct app for the correct operation for a given product.
We have many products with many operations, so a routing app is very useful.

In my initial tests I did not pay attention to the version that it opens. And this is a major flaw in my architecture. So just wondering if this is in the road mapped to be fixed. If its about 6 months away I can probably wait. Otherwise I need to come up with an alternate solution.
Thank you.

@Pete_Hartnett Any update on this?

I believe I found a work around to load a version other than the development version. Follow all the steps just as @jjj laid out with one small change. Instead of using the “Run” button at the top of the window, navigate to the “Versions” section of the app


Click “Run” for the version you would like to have the link for

Then continue with the same process from @jjj post.

The one issue I see with this method is when the app is updated to a newer version. I have the majority of my apps setup to compare the current running version with a Tulip Table containing the most recently published version. The Table is updated manually or when a newer version of the app is launched for the first time. When the running version of the app is out of date it will automatically restart the app, which will launch the most recently published version by default. Depending on the number of users that would utilize the link, it may be annoying for the app to restart immediately each time you click the link/shortcut to keep it up to date.


@jboyle Woo, collaboration!!! :muscle:

1 Like

Hi @jjj there is even more :slight_smile:

the captured Link will look like so: tulip-player://xxxxxx
If you send this by eMail it will usually not be clickable.

just change the link to:
this link will be clickable and works the same.

You want to jump to a specific step?
Go to View for the specific version.

Go to the specific step.
go to Run
capture the networc activity from Run from curent step

You want to open the latest Version, but your older versions of the app do not have a version check?
Or you want to make the link invalid later?
This is kind of an exceptional Workaround:
Make a Link to a new app, that has a transition to your actual app you want to link to “on step enter” or on a timer.
Later, you can disable the transition or post a “no longer valid” message. Therefore you need to make sure, to reload the jumper app on the latest version first.

Again: This will be an exceptional workaround, since you don’t want to build hundreds ob jumper apps…