Trigger if interactive table is blank

I would need a trigger that go to a specific step if the interactive table (after I set filters) is blank. Is there a way to create this action?
Or is there a if condition for a hole table and then you can say, if there is no data with… in the table then…?
Thank you

hello @katha,

this can be done using the Table API to get a count of records that match the filters you set.

here’s a quick guide on how to do this:

  1. Create a Connector Function to count the records in the Table with the filters (more info.:
  2. run the connector function with the filters you set:
  3. check the returned count from the Connector Function, and implement logic based on that value:

in the case that’s shared here we are simply showing a message, but you could navigate to a given step.

does this help you build what you’re attempting to build?? let me know if I can clarify something!!

hello @gio,
I have some issues and during the running of the app appear the error: connector function failed. Have you any idea where the problem could be ?

hello @katha,

I notice that the endpoint does not include /count at the end it. could you try adding it after the Table ID and letting us know if this solves it??


@gio. Thank you for your help but it still not working. So it should be right?

@katha, that looks correct to me.

could you press the Test button at the top right of that screen and send a screenshot??



OK, thanks @katha!! it looks like the Authentication details are incorrect (username/password). the Authentication to be used is not the one to Login to Tulip but the one for the API. if you search for Testing the API in here:, you can see where you can find the credentials that need to be entered.

let me know how that goes.

hello @gio, thank you for your response but I still have some issues:

  1. If I use the API documentation it seems that it doesn’t give me the right URL:

  1. problem: I wrote the URL by my own in the box, but I don’t know how I can connect the input with the filter in the URL box (in your example it was “minimum” and appears in grey).

hello @katha,

  1. do you mean that the parameters for the filters are incorrect?? were you able to enter the Authentication (API Key & Secret) in the Connector Details?? if so, were you able to Authenticate the request??
  2. to access the input in your function, you can enter the input between $ signs. so for example, $OrderID$ in your example. let me know if this works!!

@gio thank you,
okay problem 2 is solved, but the connector still doesn’t work. So the basic Auth is also set with API Key and Secret. And I think also that the description is from an older version of TULIP.

hello @katha, it should still work the same way!!

that information on the credentials looks correct, could you share a screenshot of the error message you’re seeing when you test the function??

hello @gio,

So now I receive always an error because I don’t know what I must insert in the request body

@katha, if you’re using the /count endpoint, the body should be empty. do you currently have anything there??

@gio, yes it is empty

@katha it seems like there is not a Test Value being entered for the OrderID however. could you enter the value of an existing order and let me know what that returns?? thanks!!