Connecting OPC UA with tulip connector

Hello, I’m trying to connect OPC UA server with localhost endpoint with tulip but I’m getting error. Can anyone please Help me out with this issue? also I tried with turning off the firewall but output is same error.

Hi Ajay -

A couple questions around your connector configuration to better understand the issue (if you can provide additional screenshots, that can be helpful as well):

  • Is this the first time you are trying to connect, or was this connection working previously and no longer working now?

  • Are you using Cloud Connector Host for the “Running On” field?

  • For the agent URL, if you are using a local server, you will need a redirect so that cloud service can access the IP address - are you doing this?

  • Are there any security or auth settings that could be causing a problem with connection?

See this article for more details on my questions! How To Build Your First OPC UA Connector

Let us know on the questions above and we can continue to troubleshoot :slight_smile:

Yes ! This is the first time i was trying with this endpoint/agent URL.
Yes I’m using the cloud connector host.
for the agent URL, I’m using the local server & it is not redirected - I’ll try with this option!
No ! i have checked the auth setting and i tried with auth and without auth but the error was the same for both scenarios.

Let me know if you have luck with trying the redirect! If not, I’m happy to keep trying to debug together :slight_smile:

I’m not sure what localhost would actually be, either the connector host (in this case you’re using a cloud CH) or your Tulip instance, but either way I don’t that’s going to work.

I assume by local you mean you’re running Kepserver (based on the port) on your local machine? I think you’ll need to use your public IP (if behind a router) and port forwarding to your machine.

Let me know if I assumed anything incorrectly.

In the past I have been able to connect to local data sources through an On Prem Connector Host running on the same machine. There is some slight configuration required for your docker container, but Tulip support should be able to help with this.